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Introduction

Overview
This guide is for people bringing a Mac into a small-business environment that’s 
predominantly Windows based and most likely using Windows Server Essentials. The 
guide is also for users replacing a Windows computer with a Mac, and for system 
administrators supporting Mac users.
In this guide, you’ll learn how to integrate a Mac within your organization’s network 
environment, including how to configure your Mac to work with Active Directory and 
how to take advantage of network services, file sharing, printing, instant messaging, 
emailing, calendars, and contacts.
You’ll also learn about security at the user, local network, and remote networking 
levels. You’ll learn about data management, both migrating your data from a Windows 
computer as well as backing up your important data. You’ll also learn how to run 
Windows programs directly on your Mac, giving you total compatibility and 
interoperability with your colleagues who use Windows.

Prerequisite knowledge
This material assumes you have a basic understanding of OS X skills and terminology. 
If you’re new to the Mac, you should review Mac Basics, an Apple Support resource 
that provides an introduction to using the Mac. Mac Basics is online at 
www.apple.com/support/macbasics/.
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Network Accounts

Windows Server Essentials and Windows Server use Active Directory to provide 
accounts, authentication, and shared services for network users. Open Directory is a 
directory server implementation that enables the use of LDAP directory services. 
Whatever directory service protocol your organization uses, Mac users can effortlessly 
join existing networks and follow enterprise policies for strong authentication and 
password-protected access to network resources. Adding a Mac to a network with 
directory services is a simple process because of the network account support built 
into OS X.

Configuring a Mac to connect to a directory server
Before your Mac can use a network account, you must first configure it to connect to a 
directory server. This process is called binding.
You bind your Mac to a server in the Users & Groups pane of System Preferences, and 
you need to authenticate as an administrator to start the process. In the next steps, 
you’ll learn how to bind to an Active Directory server and an Open Directory or LDAP 
server.
First, you’ll bind your Mac to a network directory server using your local Mac 
administrator user account. Next, you’ll log in to the network account to leverage 
network accounts, authentication, and resources.
To bind to an Active Directory server:

Before you can bind a Mac to an Active Directory server, you’ll need the following 
pieces of information from your server administrator:
• Active Directory server domain name
• Active Directory server administrator user name and password
Note: Your server administrator may also specify the computer ID that you should use 
for your computer.

1. Choose Apple menu > System Preferences.
2. Click Users & Groups.
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3. If the lock icon is locked, unlock it by clicking it and entering the name and password 
of an administrator account.
Click Login Options. Then click Join.
Note: If you’ve previously joined a directory server, click Login Options. Then click Edit.

4. In the dialog that appears, click the Add (+) button.

5. In the Server field, enter the Active Directory server domain name (or IP address) 
provided by your server administrator.
When OS X identifies the address as one for an Active Directory server, the dialog 
expands to display the Active Directory Settings fields.

6. Enter the Active Directory user name and password provided by your server 
administrator.
Optional: You can edit the ID that you want Active Directory to use for your server.
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The Client Computer ID is preset to the name of the computer. (This is the same name 
the Mac uses in the Sharing preferences.) You can change this to conform to your 
organization’s naming convention for computers in the Active Directory domain. If 
you’re not sure, check with the server administrator.

7. Click OK.
This creates a record for your Mac in the Active Directory domain. A green dot 
displayed next to the server name means that the connection is working.
To bind to an Open Directory or LDAP server:

When adding an Open Directory server, you need the following information from the 
server administrator:
• The server name or IP address
• Secure Sockets Layer (SSL) protocol requirements

1. Choose Apple menu > System Preferences.
2. Click Users & Groups.
3. If the lock icon is locked, unlock it by clicking it and entering the name and password 

of an administrator account.
4. Click Login Options. Then click Join.

Note: If you’ve previously joined a directory server, click Login Options. Then click Edit.
5. In the dialog that appears, click the Add (+) button.
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6. You can choose a server from the pop-up menu or manually enter the server’s domain 
name (or IP address).

7. Click OK.
OS X connects to the directory server. You’ll be notified if the directory server doesn’t 
provide a secure connection via SSL and be given the option to continue or cancel the 
connection to the server.

You’ve bound your Mac to an LDAP server. Now you can log in to the LDAP server 
using your network user account.

Using network accounts
In the previous steps, you bound your Mac to a network directory server using your 
local Mac user account. To access network resources, you need to log in using a 
network account. You’ll need a network account user name and password from your 
server administrator.
For Active Directory accounts, the user name can be in one of three formats:
• shortname

• shortname@domain.com

• DOMAIN\shortname

To log in using a network account:
1. If you’re currently logged in on your Mac, log out by choosing Log Out from the Apple 

menu.
OS X logs you out and a login window lists all the local user accounts, followed by 
Other.
If your computer has only one local user account, OS X displays the login screen for 
that account when you log out. Click the left arrow icon in front of the account name 
to access the Other login button.

2. Click Other and enter the network account user name and password provided by your 
server administrator.

3. Press Return or click the Log In (right arrow) button.
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You’re now logged in to your Mac with the account provided by the directory server. 
Your Mac is fully integrated into the network.

Summary
In this chapter, you learned the steps for setting up a Mac to connect to a directory 
server. You should now be able to:
• Get the information from the directory server administrator necessary to bind a Mac 

to a directory server.
• Bind a Mac to a directory server.
• Log in to a Mac with a network user account.
After completing these steps, your Mac can take advantage of user authentication and 
network resources provided by your organization’s directory server. OS X includes 
built-in support that makes this process simple.
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File Sharing

Organizations constantly share files and resources across networked computers. OS X 
supports a variety of popular file server protocols. In this chapter, you’ll learn how to 
connect your Mac to file servers. You’ll also learn how to configure personal file sharing 
to let other network users access files on your Mac.

Connecting to file servers
You can connect to Mac and Windows computers that have file sharing turned on, and 
to file servers that are using the AFP, SMB/CIFS, NFS, WebDAV, and FTP protocols. To 
access shared files stored on personal computers and file servers on your network, you 
can browse for the computer by name in a Finder window, or enter the computer’s IP 
address directly in the “Connect to Server” dialog.
To connect to a computer or server by browsing:

1. In the Finder, choose Go > “Connect to Server.”

2. Click Browse.
The computers on your network that have sharing turned on are listed in a Finder 
window.

3. Search for the name of the computer or server.
You may also need to know the network area or workgroup where the computer is 
located.
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4. When you locate the shared computer or server you want, select it and click Connect 
As.

5. If you want to select volumes or shared folders on the server,  enter your user name 
and password and select volumes or shared folders.
Note: To make it easier to connect to the server in the future, select “Remember this 
password in my keychain” to add your user name and password for the server to your 
keychain. You’ll gain access automatically next time you connect to the server.
To connect directly to Windows file servers:

1. In the Finder, choose Go > “Connect to Server.”
2. Type the network address for the computer or server in the Server Address field using 

one of these formats:
smb://DNSname/sharename

smb://IPaddress/sharename

where DNSname is the domain name of the server, IPaddress is the server’s IP address, 
and sharename is the name of the shared volume to be mounted.
Note: SMB stands for the Server Message Block protocol, which is used mainly by 
Windows computers to provide shared network access. SMB is also known as the 
Common Internet File System, or CIFS.
If you’ve connected to the file server recently, you can also choose it from the Recent 
Servers (the clock) pop-up menu.

To add a computer or server to your Favorite Servers list, click the Add (+) button after 
you enter the address. You can double-click the server’s address in the list to connect 
to it next time.

3. Click Connect.
4. For “Connect As,” select Registered User and enter the user name and password that 

the server administrator gave you.
You’ve now used your Mac to access files stored on network file servers. You may also 
want to set up your Mac so other network users can access your files with personal file 
sharing. The next section shows you how to enable personal file sharing on your Mac.

Personal file sharing
To allow other network users to connect to your Mac, you must turn on file sharing in 
System Preferences. You may want to create a special sharing account on your Mac to 
maintain the security of your unshared files.
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To authorize users to access your shared files, provide them with the following 
information:
• The IP or Bonjour (the OS X auto network-discovery feature) address of your Mac
• The user account name for the account on your Mac that has file sharing turned on
• The user account password for the file-sharing account on your Mac
Note: If you want to use a user account that existed before you installed the latest 
version of OS X, you may need to reset the password for the account in Users & 
Groups preferences.
Before you set up sharing, you should select which folders to share with network users 
and which permissions users will have. By default, the Mac administrator account has 
full read and write access, and all others have only read access.
To select which folders to share:

1. Choose Apple menu > System Preferences.
2. Click Sharing.
3. Select File Sharing in the Service list on the left.
4. At the bottom of the Shared Folders list, click Add (+).
5. Select the folder you want to share, and click Add.

By default, any user set up on your Mac in Users & Groups preferences can connect to 
your Mac over the network. A user with an administrator account can access your 
entire computer.
To give only specific users access to a folder:

1. Select the folder in the Shared Folders list.
2. At the bottom of the Users list, click Add (+). Then do one of the following:

• Select a user from Users & Groups, which includes all users of your Mac.

• Select a user from Network Users or Network Groups, which includes everyone on 
your network.

• Select a person from your contacts. Create a password for the person. Then click 
Create Account.

3. In the Users pane, select the user name and choose the appropriate level of access:
• No Access: The user can’t see or copy files from the folder. This option is available 

only for Everyone. To deny access to files or a folder for other users, select the user 
and click Delete (–).

• Read & Write: The user can see and copy files to and from the folder.
• Read Only: The user can view the contents of the folder but can’t copy files to it.
• Write Only (Drop Box): The user can copy files to the folder but can’t view its 

contents.
4. Give authorized users your computer’s IP or Bonjour address and the user name and 

password they should use to share files with your computer.
You can see your computer’s Bonjour address in the Sharing pane.
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After you grant users access and configure your folder permissions, you need to set 
the protocol that your computer uses to share files. You can share files using Apple 
Filing Protocol (AFP) or Server Message Block (SMB) protocol. OS X uses AFP to share 
files with other Mac computers and SMB to share files with Windows users. In the 
following section, you’ll learn how to enable file sharing on your Mac.
To enable personal file sharing for Windows and Mac users:

1. Choose Apple menu > System Preferences.
2. Click Sharing.
3. Select File Sharing. Then click Options.
4. Select “Share files and folders using SMB” or “Share files and folders using AFP.” You can 

select both options.
If you’re sharing files with Windows users:
• Be sure to select the SMB option.
• Select the On checkbox next to the name of each account on your Mac that 

Windows users will use to access shared files on your Mac. (To keep your computer 
secure, consider creating a special sharing account for Windows users in Users & 
Groups preferences.

• Enter the password that you set for the Sharing account in System Preferences > 
Users & Groups.

Note: Because the passwords for some Windows users may be stored less securely, you 
should disable Windows users’ accounts when they’re not in use. Deselect the On 
checkbox next to an account to disable the account. Be sure to disable the account 
before you turn off file sharing on your computer. Otherwise, the password is still 
active and is stored in a less secure manner.

5. Click Done.
You’ve enabled personal file sharing on your Mac. Authorized network users can now 
access the files and volumes you chose to share.

Summary
In this chapter, you learned how to share files. You should now be able to:
• Access shared files on a network using a Mac via browsing and direct connection.
• Set up folder and user permissions for personal file sharing.
• Enable personal file sharing over SMB and AFP on a Mac.
• Provide network users with a user name and password so they can access files on 

your Mac.

14



Email, Calendars, and Contacts

OS X has out-of-the-box support for email, contacts, and calendars using standards-
based servers including Microsoft Exchange Server, POP, SMTP, and more. With OS X, 
you can easily connect directly to shared services such as email, calendars, and global 
address lists. In this chapter, you’ll learn how to configure the OS X Mail app to send 
and receive email via common server types. And you’ll learn how to configure 
Contacts to access shared contacts. You’ll also learn how to configure Calendar to 
access shared calendar services.

Internet Accounts preferences
With Internet Accounts, you can quickly set up Mail, Messages, Calendar, and other 
apps using iCloud, Google, and other web service–provider accounts.
In the Internet Accounts pane, the list on the left shows the web service–provider 
accounts you provided information for when you first configured OS X with the Setup 
Assistant, created an account in an app, or used Internet Accounts preferences. The list 
on the right shows major services that you can set up in Internet Accounts 
preferences.
To view or change information about an account, select the account and click Details.
To remove a selected account and turn off all its features, click Delete (–).
If multiple apps use the selected account, you can stop a specific app from using the 
account by deselecting the app’s checkbox.
To add an account in Internet Accounts preferences:

1. Choose Apple menu > System Preferences.
2. Click Internet Accounts.
3. If you already added an account and it’s selected, click the Add (+) button.
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4. Click an account type, enter your account information, and follow the onscreen 
instructions.

5. Make sure the apps you want to use with the account are selected.

Connecting to an Exchange server
To connect a Mac to an Exchange server, you’ll need the following information from 
the server administrator:
• The Exchange user name
• The Exchange password

16



If the Exchange Autodiscover service isn’t enabled on the Exchange server, you’ll also 
need the fully qualified domain name for the organization’s Client Access Server (CAS), 
typically expressed in the format exchange01.example.com.
After you have the required information, you can either manually configure your Mac 
to use Exchange, or use the Exchange Autodiscover service to configure the Mac, if it’s 
enabled.
Note: Exchange support requires Microsoft Exchange Server 2007 Service Pack 1 
Rollup 4, Exchange Server 2010, or Exchange 2013.
The easiest way to set up Mail, Contacts, and Calendar to access Exchange is with the 
Exchange Autodiscover. If this feature is enabled on the Exchange server, perform the 
steps below.
To connect to an Exchange server with Autodiscover enabled:

1. Choose Apple menu > System Preferences.
2. Click Internet Accounts.
3. Click Exchange in the list of services.
4. Enter your Exchange email address and password.
5. Click Continue.

OS X uses the Autodiscover service in Exchange to get relevant account information, 
and you can start using Exchange services immediately. If Autodiscover isn’t enabled 
on the Exchange server, follow the steps below to manually configure your mail 
account.
To manually configure an account to connect to an Exchange server:

1. Choose Apple menu > System Preferences.
2. Click Internet Accounts.
3. Click Exchange in the list of services on the right.
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4. Enter your Exchange email address and password.
5. Click Continue.

Mail searches for the information it needs to finish setting up the account. If it can’t 
find the information, continue to the next step.

6. Enter a description for the account (for example, Work or Exchange).
7. In the Server Address field, enter the fully qualified domain name for the organization’s 

Exchange Client Access Server.
8. Click Continue.
9. Make sure the Contacts and Calendar checkboxes are selected to automatically set up 

those apps.
10. Click Done.

Note: To access an Exchange server from a Mac outside the organization’s network, 
confirm with the server administrator that port 443 is open on the organization’s 
firewall and Exchange Web Services (EWS) is enabled on the server.
You’ve now configured Mail for use with Exchange. You can confirm that is Mail 
configured successfully by checking your email and sending email to a colleague from 
your Exchange account.

Email with POP and IMAP servers
If your organization uses a non-Windows server to administer email services, you can 
easily configure Mail to access the non-Windows server. Common mail server 
protocols include Post Office Protocol (POP) and Internet Message Access Protocol 
(IMAP), which allow client computers to access messages on the mail server, and 
Simple Mail Transfer Protocol (SMTP) for sending messages from a client computer to 
the mail server and between mail servers.
To configure Mail to connect to POP and IMAP email services:

1. Choose Apple menu > System Preferences.
2. Click Internet Accounts.
3. Click Add Other Account in the list of services on the right.
4. Choose “Add a Mail account” and click Create.
5. Type the full name, email address, and password for the email account.
6. Click Create.

If OS X is able to identify the type of mail server and connect successfully, it will create 
the mail account and you can start sending and receiving email. If not, you’ll need to 
manually configure the account.

7. When prompted to manually create the account, click Next.
8. In Incoming Mail Server Info, select the type of email account: IMAP or POP.
9. Enter the mail server address provided by your ISP or mail server administrator.
10. Verify that the User Name and Password fields are correct.
11. Click Next.
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12. If displayed, verify that the port address and authentication type are correct and click 
Next.

13. In Outgoing Mail Server Info, enter the outgoing mail server address and 
authentication information.

14. Click Create to complete the process.
You’ve configured Mail for use with common mail server protocols. You can confirm 
that mail is configured correctly by checking your inbox or by sending a test email to 
yourself or a colleague.

Adding accounts in Mail, Contacts, and Calendars
Although you can configure accounts within Internet Accounts preferences, you may 
want to configure accounts within the Mail, Contacts, or Calendar apps.
To add a new account from the Mail app, choose Add Account from the Mail menu. 

An assistant appears that guides you through the steps to add a mail account.
If you encounter problems connecting to your mail server, you may need to verify your 
login information with your mail service or support department. To view your login 
information in Mail, choose Mail > Preferences. Then click Accounts.
For an explanation of the Account Information fields, click the Help button (?) in the 
lower-right corner.

Contacts
To add a new account from Contacts, choose Add Account from the Contacts menu. 
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An assistant appears that guides you through the steps to add a contacts account.

If your organization is using CardDAV or LDAP. for contact data, select Other contacts 
account. 
CardDAV is based on an Internet standard for accessing and sharing contact 
information. Ask your server administrator for the address of the CardDAV server that 
hosts your CardDAV account.
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An LDAP Internet account is based on an Internet standard for finding information on 
an LDAP directory server. Depending on how the LDAP server is configured, the 
information you need to provide may be complex. Your server administrator should be 
able to provide you with the correct values to enter.

You can view the accounts available to the Contacts app by choosing Contacts > 
Preferences. Then clicking Accounts.
From here, you can enable or disable individual accounts.

Calendar
To add a new account from Calendar, choose Add Account from the Calendar menu. 
An assistant guides you through the steps.
You can view a list of all of your Calendar accounts by choosing Calendar > 
Preferences. Then clicking Accounts.
From here, you can enable or disable accounts within the Calendar app.

Summary
In this chapter, you learned how to configure a Mac to access server-based mail, 
contacts, and calendar services. You should now be able to:
• Use the Internet Accounts preferences to add mail, contacts, and calendar accounts.
• Configure accounts directly from the Mail, Contacts, and Calendar apps.
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Security

OS X offers strong, easy-to-use tools for all key aspects of network and computer 
security. It’s important to maintain security at every level by protecting your user data, 
protecting your Mac system, and securing your network.
In this chapter, you’ll learn how to secure your user data by choosing a strong 
password, configuring your home folder permissions, and enabling FileVault 2. And 
you’ll learn how to protect your Mac system by setting a firmware password and 
enabling antivirus software. You’ll also learn how to enable network security by 
configuring the OS X firewall and VPN access services.

User account security
Choosing a password
It’s important for everyone to create strong passwords. A weak password can be 
compromised, allowing access to your Mac, your files, and your personal email 
account, as well as sensitive company data. The password you choose is very 
important for your computer’s security because you’ll use it to install software, set up 
accounts, access the keychain, and log in to your computer.
The most secure passwords are created from a combination of random uppercase 
letters, lowercase letters, special characters (such as $, @, !, and #), and numbers. For 
example, L1quid$m0ke is a good password because it’s a long, uncommon phrase 
with letters replaced by special characters and numbers.
OS X includes Password Assistant, a feature that checks the strength of a password or 
generates a strong password for you. You can specify the length and type of password 
you’d like it to generate.
You can choose from the following methods for setting a password:
Manual  You enter a password; then Password Assistant reports the robustness of that 
password on a Quality bar. If the password is weak, Password Assistant offers tips for 
increasing the quality of the password.
Memorable  You adjust the password’s Length setting; then Password Assistant 
generates a list of memorable passwords consisting of words from a dictionary and 
some random characters. An example is “wept1]puller”.
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Letters & Numbers  You adjust the password’s Length setting; then Password Assistant 
generates a list of passwords with a combination of letters and numbers. An example 
is “tSFCF4lLh2yc”.
Numbers Only  You adjust the password’s Length setting; then Password Assistant 
generates a list of passwords containing only numbers. An example is “007515850186”.
Random  You adjust the password’s Length setting; then Password Assistant generates 
a list of passwords containing random characters. An example is “)RO{AFKTDc\0”.
FIPS-181 compliant  You adjust the password’s Length setting; then Password Assistant 
generates a password that is FIPS-181 compliant. An example is “cdavicourgok”.
To use Password Assistant to create a password:

1. Choose Apple menu > System Preferences.
2. Click Users & Groups.
3. Select a user, and click Change Password.
4. Click Change Password to proceed.
5. Click the Key button (  ) to the right of the “New password” field. This opens the 

Password Assistant.
6. From the Type pop-up menu, choose the type of password that meets your company’s 

security standards.

To choose the number of characters you’d like for an automatically generated 
password, move the Length slider to the left or right.

7. Click Change Password.

By setting a strong password, you’ve protected your personal data from unauthorized 
access.
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Locking the computer screen
If you want to stay logged in to your computer while you’re away from it but need to 
prevent others from using it, you can lock the screen. When you return to the 
computer, type your login name and password to continue working.
To require authentication to wake your computer:

1. Choose Apple menu > System Preferences.
2. Click Security & Privacy.
3. Click General.
4. Select “Require password…after sleep or screen saver begins.”

You can adjust the length of delay before a password is required in the pop-up menu.

Locking the screen doesn’t prevent other users from turning off the computer, 
restarting it, and logging in to their own account. If you think this could happen, be 
sure to save your work before you leave your computer.
To lock your screen quickly when fast user switching is enabled, click your name at the 
top right of the screen and choose Login Window from the menu. This keeps your 
apps open and undisturbed but locks your computer.
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Disabling automatic login
If your computer starts up without displaying the login window, it’s set up to log in to 
a specified user account automatically. When multiple users share a computer, it’s best 
to set up a unique account for each user and disable automatic login. Using separate 
accounts protects each user’s information and makes the computer more secure.
Important: Because automatic login means anyone can access your Mac simply by 
restarting it, you should disable automatic login to keep your computer secure. If 
automatic login is enabled, make sure the computer isn’t set up to automatically log in 
to an account with administrator privileges.
To turn off automatic login:

1. Choose Apple menu > System Preferences.
2. Click Users & Groups.
3. Click the lock icon to unlock it. Then type an administrator name and password.
4. Click Login Options.
5. Choose Off from the “Automatic login” pop-up menu.

The next time you start up your computer, the login window will appear and you’ll 
need to enter a user name and password to log in.

System security
Security goes beyond setting passwords and encrypting data, so OS X supports 
additional methods to secure the system itself. FileVault 2 encrypts the contents of the 
startup disk. Setting a firmware password helps keep unauthorized boot devices from 
bypassing the OS-level security. And antivirus protection helps ensure that any viruses 
from other operating systems on the network won’t threaten your data.

FileVault 2
You can use FileVault 2 to protect the files on your startup disk from being seen or 
copied. FileVault 2 disk encryption encodes the information stored on your disk so it 
can’t be read unless the login password is entered.
If you store sensitive information on your computer, consider using FileVault disk 
encryption. For example, if you carry all your company’s financial data on your portable 
computer and you lose it, someone could access sensitive data that might hurt your 
business. If you’re logged out of your account when your computer is lost but the data 
is encrypted, your information is protected.
The disk encryption in OS X uses the government-approved encryption standard, the 
Advanced Encryption Standard with 128-bit keys (AES-128).
When you turn on FileVault 2, you get a recovery key. You can use the recovery key as 
a safety measure to unlock the disk if you forget the administrator’s login password.
To ensure security, when you turn on FileVault 2, other security features are also turned 
on. For example, a password is required to log in after waking from sleep and after 
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leaving the screen saver. After the initial startup, only users enabled in FileVault will be 
able to log in; other users will need an administrator to log in first.
WARNING: Don’t forget your administrator password. If you turn on disk encryption 
and forget your login password, your Apple ID, and your recovery key, you won’t be 
able to log in to your account, and your files and settings will be lost forever.
To set up FileVault 2:

1. Choose Apple menu > System Preferences.
2. Click Security & Privacy. Then click FileVault.
3. Click the lock icon to unlock the pane. Then type an administrator name and 

password.

4. Click Turn On FileVault.
OS X presents the option to use your iCloud account to reset your password, or to 
create a recovery key.
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5. Choose “Create a recovery key and do not use my iCloud account” option and click 
Continue.
A dialog appears with a recovery key that you can use to unlock the disk if you forget 
your password.

6. Copy the recovery key and store it in a safe place. If you forget your password and lose 
the recovery key, all data on your disk will be lost.

7. Click Continue.

8. If your Mac has multiple user accounts, you can enable these users to decrypt all files 
on the startup disk. If you choose not to enable your Mac users to unlock the disk, you 
(the administrator user on your Mac) will need to unlock the disk.

9. Click Continue.
10. Click Restart.

After you restart your Mac, the encryption process begins. It may take some time to 
encrypt your disk, depending on how much information you have on the disk. 
However, you can use the computer as usual while the disk is being encrypted.

Firmware password
You can set a firmware password to enable low-level hardware protection for your 
Mac. A firmware password helps prevent unauthorized users from booting your Mac 
from an external hard disk, optical disc, or USB flash drive.
To set a firmware password:

1. Restart the computer and hold down Command-R to start up using the Recovery HD 
partition.

2. When the OS X Utilities window appears, choose Utilities > Firmware Password Utility.
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3. Click Turn On Firmware Password.
4. Enter a password in the Password and Verify fields.
5. Click Set Password.
6. Click Quit Firmware Password Utility.

You can test your settings by attempting to start up in single-user mode. Restart the 
Mac while holding down the Option key. If the Mac displays a lock icon with a 
password field, changes made by the Firmware Password Utility were successful. Enter 
the firmware password to continue.
To reset a firmware password:

To reset a lost firmware password on later-model computers, such as MacBook Air (late 
2010 and later), MacBook Pro (early 2011 and later), iMac (mid-2011 and later), and 
MacBook Pro with Retina display, take the Mac to an Apple Retail Store or Apple 
Authorized Service Provider. For more information, go to support.apple.com/kb/
TS3554.
To reset a lost or forgotten firmware password on earlier computers, you’ll need to 
access the inside of the Mac (just as resetting a PC BIOS password requires removing 
the onboard battery).

1. Shut down the Mac.
2. Change the memory configuration by adding or removing RAM.
3. Start up the Mac.

This clears the firmware password.
4. Shut down the Mac again.
5. Return the RAM to its original configuration.
6. Start up the Mac.

Antivirus protection
OS X offers a multilayered system of defenses against viruses and other malicious 
apps, or malware, with virtually no effort on your part. For example, through a 
technique called “sandboxing,” OS X prevents hackers from harming your programs. 
Sandboxing restricts what actions programs can perform on your Mac, what files they 
can access, and what other programs they can launch.
Other automatic security features include Library Randomization, which keeps 
malicious commands from finding their targets, and Execute Disable, which protects 
the memory in your Mac from attacks.
Viruses are uncommon in OS X, but it’s a good idea to be aware of them, especially 
when exchanging files with computers on other operating systems. Regular use of 
commercial antivirus software can help prevent virus forwarding.

Gatekeeper
Gatekeeper makes it safer to download apps by protecting you from accidentally 
installing malicious software on your Mac. Gatekeeper gives you three security options 
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for downloading and installing apps for your Mac. The safest place to download apps 
for your Mac is the Mac App Store. Apple reviews each app before it’s added to the 
store, and if there’s ever a problem with an app, Apple can quickly remove it from the 
store. Gatekeeper also makes it safer for you to download and install software from 
anywhere on the web.
Developers can get a unique Developer ID from Apple and use it to digitally sign their 
apps. The Developer ID allows Gatekeeper to verify that apps were developed by 
known developers and haven’t been tampered with. If an app was developed by an 
unknown developer—one without a Developer ID—Gatekeeper can keep your Mac 
safe by blocking the app from being installed.
To set the allowed software sources:

1. In the Apple menu, choose System Preferences.
2. Click Security & Privacy. Then click General.

3. Choose the software sources you want to allow.
• Mac App Store: You can download apps only from the Mac App Store. Apple 

identifies all the developers of apps in the Mac App Store and reviews each app 
before accepting it. When you download an app from the Mac App Store, OS X 
checks the app before it opens for the first time to make sure it hasn’t been 
modified since the developer shipped it. If there’s ever a problem with an app, Apple 
removes it from the Mac App Store.

• Mac App Store and identified developers: You can download apps from the Mac App 
Store and apps from identified developers. Although apps from outside the Mac 
App Store aren’t reviewed, identified developers are registered with Apple. If 
problems occur with an app, Apple can revoke its authorization. OS X checks the 
app before it opens for the first time to make sure it hasn’t been modified since the 
developer shipped it.

• Anywhere: You can download apps from anywhere. This setting turns off 
Gatekeeper. This is the least secure setting, because OS X doesn’t check the app’s 
source or whether the app has been modified or broken.

In addition to apps, other types of files may be unsafe. Scripts, web archives, and Java 
archives can harm your system. An alert appears when you first try to open these files. 
Not all files like these are dangerous, but you should be careful when opening any 
downloaded file.
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To open the app that was blocked by Gatekeeper:
1. Press the Control key, and click the app.
2. Choose Open from the shortcut menu, and click Open.

After you’ve opened an app, it’s considered an exception to the security settings and 
you can double-click to open it.

Network security
In addition to user account and system security, network security is also very 
important to organizations. The OS X firewall helps protect your Mac from 
unauthorized incoming access by other systems on both a local network and the 
Internet. The virtual private network (VPN) service provides a secure way for your 
computer to remotely access networks.

OS X firewall
You can use the OS X personal firewall to block unwanted incoming connections to 
your computer. A firewall protects the services on your computer from other 
computers on the network or Internet. Services that are turned on in Sharing 
preferences already appear in the list of services that other computers can connect to. 
To prevent incoming connections to one or more of these services, you must turn off 
the service in Sharing preferences.
To turn on the OS X firewall:

1. Choose Apple menu > System Preferences.
2. Click Security & Privacy. Then click Firewall.
3. Click the lock icon to unlock it. Then type an administrator name and password.
4. Click Turn On Firewall to enable the firewall.
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To configure advanced firewall options:
1. In the Firewall pane of Security & Privacy preferences, click Firewall Options.

2. You can select from three advanced firewall options:
• Select the “Block all incoming connections” checkbox to allow incoming connections 

for basic Internet functions only. You can still check email and browse the web, but 
this mode prevents all sharing services in the Sharing pane of System Preferences, 
such as File Sharing and Screen Sharing, from receiving incoming connections. To 
use sharing services, deselect this option.

• Select the “Automatically allow signed software to receive incoming connections” 
checkbox to allow apps that are already signed by a valid certificate authority to be 
automatically added to the list of allowed apps, rather than prompting you to 
authorize them. For example, because iTunes is already signed by Apple, this setting 
automatically allows it to receive incoming connections through the firewall.

• Select the “Enable stealth mode” checkbox to prevent unauthorized or unexpected 
incoming probes from receiving a response from your Mac. Your computer will still 
answer requests for authorized apps, but other unexpected requests, such as 
network pings from other computers trying to discover your Mac, won’t get a 
response.

3. Click OK when you’re done making changes to the advanced settings.
You’ve configured the built-in firewall service and increased the security of incoming 
network connections.
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Virtual private network
With virtual private network (VPN) access, you can use network services while you’re 
offsite and simultaneously prevent access by unauthorized individuals. OS X supports 
standards-based L2TP over IPSec, PPTP, and Cisco IPSec to provide encrypted VPN 
connections with a built-in VPN client. To connect to a VPN, get the VPN server 
address, VPN type, VPN account name, and user authentication information from the 
network administrator.
To set up a VPN connection:

1. Choose Apple menu > System Preferences.
2. Click Network.
3. Click the Add (+) button at the bottom of the network connection services list. Then 

choose VPN from the Interface pop-up menu.

4. Choose which kind of VPN connection you want to set up from the VPN Type pop-up 
menu, and give the VPN service a name.

5. Click Create.
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6. Enter the server address and the account name for the VPN connection.

7. Click Authentication Settings, and enter the user and machine authentication 
information.

8. Click OK. Then click Apply.
9. Click Connect.
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10. Select “Show VPN status in menu bar” to use the VPN status icon to connect to the 
network and switch between VPN services.

You’ve configured your Mac to access a VPN so you can connect remotely to your 
organization’s network while maintaining enhanced security.

Summary
In this chapter, you learned how to secure a Mac at the user data, system, and network 
levels. You should now be able to:
• Improve user account security for your Mac using strong passwords.
• Configure FileVault to prevent unauthorized access to the data on your disk.
• Set a firmware password for low-level system protection.
• Configure the OS X firewall to restrict incoming network access to services and data 

by other computers.
• Configure your Mac to securely access a remote network using the VPN service.
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Printing from OS X Computers

With OS X, you can quickly connect to and share a local printer as well as use remote 
printers on the network. Mac computers can share printing resources with Windows 
computers with relative ease, making it much easier to ensure that printers can be 
accessed by computers on multiple platforms.
In this chapter, you’ll learn how to configure your Mac to print to a locally connected 
printer and how to share the printer with network users on other platforms. You’ll also 
learn how to set up your Mac to connect to network printers using a variety of 
common printer protocols and how to optimize network printers.

Connecting to a USB printer
To print to a USB printer, first make sure it’s connected to your computer. Then add it 
to your list of available printers. For most USB printers, the printer is added to the list 
automatically when you connect it.
To add a USB printer to your list of printers:

1. Follow the instructions that came with the printer to set it up and connect it to your 
computer.

2. In the App Store, check for available updates to make sure OS X has the latest 
information about printer software it can download from Apple.
OS X updates its list of available printer software and downloads the software as 
needed when you add printers.

3. Open a document to print, and choose File > Print.
4. Open the Printer pop-up menu, and choose your printer.

If you don’t see your printer, contact the printer’s manufacturer for more information.
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Setting up a printer to print wirelessly
If your printer has built-in Bluetooth or Wi-Fi, you can print to it wirelessly.
To set up a printer with built-in Wi-Fi:

1. Follow the directions that came with the printer to set it up and connect it to your 
Wi-Fi network.

2. In the Mac App Store, check for available updates to make sure OS X has the latest 
information about printer software it can download from Apple.
OS X updates its list of available printer software and downloads the software as 
needed when you add printers.

3. Open a document to print, and choose File > Print.
4. Open the Printer pop-up menu, and choose your printer in the Nearby Printers section 

of the menu.
To set up a Bluetooth printer:

1. Follow the instructions that came with the printer to set it up.
2. In the Mac App Store, check for available updates to make sure OS X has the latest 

information about printer software it can download from Apple.
OS X updates its list of available printer software and downloads the software as 
needed when you add printers.

3. Open a document to print, and choose File > Print.
4. Open the Printer pop-up menu, and choose Add Printer.
5. Select your Bluetooth printer. Then click Add.

If your printer isn’t in the list, Bluetooth may not be enabled on your computer. You 
can turn it on in Bluetooth preferences.

Printing to a network printer
In addition to connecting to local printers, OS X can easily connect to network 
printers. You can connect to printers on your local network that use Bonjour (the OS X 
auto network-discovery feature), IP, and Open Directory, as well as shared printers.
Important: If you connect a printer that has a scanner to a local network, other 
computers on the local network can see what’s on the scanner bed. If you scan 
documents with sensitive information, connect the scanner to your computer’s USB 
port.

1. If you’re setting up a printer, follow the instructions that came with it to set it up and 
connect it to your network.

2. In the Mac App Store, check for available updates to make sure OS X has the latest 
information about printer software it can download from Apple.
OS X updates its list of available printer software and downloads the software as 
needed when you add printers.

3. Open a document to print, and choose File > Print.
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4. Open the Printer pop-up menu, and choose your printer in the Nearby Printers section 
of the menu.
If you don’t see your printer, choose Add Printer from the Printer pop-up menu.
A dialog appears listing any Bonjour, IP, shared, and Open Directory printers on your 
local network. It may take a minute or two for your printer to appear.

5. Select your printer when it appears in the list. Then click Add.
OS X automatically uses AirPrint if your printer supports it, or it selects printer software 
(also called a printer driver) and downloads it from Apple if necessary.
If you don’t see your printer in the list, see the following sections: “Setting up a printer 
shared by a Windows computer via SMB/CIFS” or “Setting up an IP printer.”
A Mac can usually detect whether a printer has special accessories installed, such as 
additional paper trays, extra memory, or a duplex unit. If it can’t detect them, a dialog 
will appear so you can specify the accessories. Make sure the settings in that dialog 
accurately reflect your printer’s installed accessories so you can take full advantage of 
them.

Setting up a printer shared by a Windows computer via SMB/CIFS
You can print to a printer connected to a Windows computer if it supports SMB/CIFS. 
The printer’s owner must set it up to be shared and must use only the following 
characters in the name of the printer and computer: A-Z, a-z, 0-9, !, $, *, (, ), _, +, -, ‘, 
and . (period).
To print to a printer shared by a Windows computer:

To add an SMB/CIFS printer to your list of available printers, you need to know the 
printer’s workgroup name. You may also need to know the user name and password 
for the printer.

1. Open a document to print, and choose File > Print.
2. Choose Add Printer from the Printer pop-up menu. Then click Windows.

A network browser appears, listing the Windows workgroups on your network.
3. Select the printer from the network browser.

To locate the printer in the browser, click the workgroup. Then click the print server 
(the computer that’s sharing the printer). If prompted, enter the user name and 
password for the printer.

4. Choose the printer software appropriate for the shared printer from the Use pop-up 
menu.
Be sure to choose the correct printer model for the printer you’re adding. For more 
information, see the documentation that came with the printer. If you have an HP PCL-
compatible printer that’s not listed, choose the printer model that most closely 
matches your printer.

5. Click Add.

37



If you can’t add the Windows printer you want, the printer software your Mac has for it 
may not support printing via SMB/CIFS. Update the printer software on your Mac, or 
ask your network administrator for help.

Setting up an IP printer
If a network printer you want to use isn’t in the list of available printers, you can add it 
as an IP printer. The printer must support one of these printing protocols: Internet 
Printing Protocol (IPP), Line Printer Daemon (LPD), or HP Jetdirect (Socket).
To print to a printer shared by a Windows computer:

You ‘ll need to know the network printer’s IP address or host name, printing protocol, 
and model number or printer software name. If the printer uses a special queue, you’ll 
also need to know the queue name. See the person who manages the printer or server 
for help.
Before you begin, choose Apple menu > Software Update to make sure OS X has the 
latest information about printer software that it can download from Apple. Check that 
the printer is connected to your network and ready to print.
To add an IP printer:

1. Open a document to print, and choose File > Print.
2. Choose Add Printer from the Printer pop-up menu.
3. Click IP, and enter the printer information, using the following table as a guide.

Option Description

Address Enter the printer’s IP address (a number that looks like 
192.168.20.11) or host name (for example, 
printer.example.com).

Protocol From this pop-up menu, choose a printing protocol that your 
printer supports.
• Internet Printing Protocol – IPP: Modern printers and printer 

servers use this protocol.
• Line Printer Daemon – LPD: Older printers and printer 

servers may use this protocol.
• HP Jetdirect – Socket: HP and many other printer 

manufacturers use this protocol.

Queue If your printer requires it, enter the queue name for your 
printer. If you don’t know the queue name, try leaving it 
blank, or see your network administrator.

Name Enter a descriptive name for the printer (for example, “Color 
Laser Printer”), so you can identify it in the Printer pop-up 
menu.
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Location Enter the printer’s location (for example, “outside my office”), 
so you can identify it in the Printer pop-up menu.

Use If this pop-up menu doesn’t show the printer software 
appropriate for the printer, choose Select Printer Software, 
then select your printer in the Printer Software list.
If that list doesn’t include your printer, try downloading and 
installing the printer software (also called a printer driver) 
from the printer manufacturer. You can also try choosing 
generic printer software from the pop-up menu.

Specifying your printer’s features
If your printer’s options weren’t accurately detected when you added it to your list of 
printers, you can specify the options yourself. Or if you added or changed a printer 
feature after adding the printer to your list of printers, you may have to update its 
options.
For example, the Print dialog may not display options for two-sided printing because 
the printer’s duplex unit wasn’t detected. Or you may have moved an extra paper tray 
from one printer to another, and your printer didn’t detect the change.
Note: If your printer uses AirPrint, the printer’s features are determined automatically, 
and you can’t turn any features on or off.
To specify your printer’s features:

1. Choose Apple menu > System Preferences. 
2. Click Printers & Scanners.
3. Select your printer in the list at the left.
4. Click Options & Supplies, then click Options.
5. Select the options you want to see when you print.

Sharing your printer
You can share a printer that’s connected to your Mac with another Mac, or with a UNIX 
computer. The computers must be on the same local network as your Mac, and the 
Mac users must have OS X v10.4 or later. You can’t share a printer that’s connected to 
your Mac with Windows computers.
Printer sharing is for printers attached directly to your Mac. You don’t need to share 
network printers, because they’re already shared on the network.
To share your printer:

1. Choose Apple menu > System Preferences. 
2. Click Sharing.
3. Select the Printer Sharing checkbox if it’s not already selected.
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4. Under Printers, select the printer you want to share.
When you share a printer, all users on your network (Everyone) can use it by default. If 
you want to restrict access to specific people, continue with step 5.

5. Click Add (+) at the bottom of the Users list. Then do one of the following:
• Select a user from Users & Groups, which includes all the users of your Mac.
• Select a user from Network Users or Network Groups, which includes everyone on 

your network.
• Select a person from your contacts. Create a password for the person. Then click 

Create Account.
• Click New Person. Enter a name and password for the person, click Create Account, 

and select the person from Users & Groups.
When you add people to the Users list, access to the shared printer is reset to No 
Access for users on your network (Everyone). If you want to provide access to Everyone 
again, click the triangles and choose Can Print.
To remove a user from the list, select the user’s name and click Remove (–). You can’t 
remove Everyone.

Summary
In this chapter, you learned different ways to use a Mac with local and network 
printers. You should now be able to:
• Configure a Mac to print to a USB printer.
• Configure a Mac to print to a network or Windows printer.
• Share a local printer with network users.
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Instant Messaging

Organizations use instant messaging to keep local and remote team members and 
leaders in contact with each other. Messages is the OS X instant messaging app. It 
includes support for messaging using iMessage, AIM, Jabber, Yahoo, and Google Talk 
accounts. Your instant message appears in a window on your colleague’s screen almost 
as soon as you send it, so your colleague can respond right away. You can use 
Messages to send files to people across the Internet or on your local network. And you 
can set up audio and video chats to keep in touch with colleagues around the world.
In this chapter, you’ll learn how to set up a Mac for instant messaging with Messages 
and AIM, Jabber, Google Talk, and Yahoo accounts.

About iMessage and iOS devices
iMessage is a secure messaging service that you can use to send and receive messages 
on your Mac, iPhone, iPad, and iPod touch. You don’t have to wait for your colleagues 
to go online—you can send them messages and they’ll either receive the messages on 
their mobile devices or see them the next time they open Messages on a Mac.
When someone sends you an iMessage, you’ll receive it on all your mobile devices 
with iOS 5.0 or later that are set up to use the same email address. When you view an 
iMessage conversation, you’ll see all messages sent on a Mac or on mobile devices, so 
you can talk to your friends wherever you are.
Instead of using buddy names, you can use phone numbers or email addresses to 
send messages to people. If you entered their contact info in Contacts, you can enter a 
name and select which phone number or email address you want to send the 
message to. When you send a message to a friend’s phone number, your friend will 
receive your message on iPhone but not on any other devices.
You need an Apple ID to use Messages with iMessage. If you have an iTunes or iCloud 
account, you have an Apple ID. If you don’t have an Apple ID, you can create one in 
Messages.
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Jabber accounts
Messages supports the Extensible Messaging and Presence Protocol (XMPP)—also 
known as Jabber—which means it can communicate directly with popular messaging 
services. It also supports Bonjour for automatically discovering Messages users on your 
organization’s network. Messages supports the high-quality H.264/AVC codec for video 
chats.
You must have a Jabber account to send messages to people who use Jabber 
accounts.
You can get a Jabber account from a Jabber service provider, or your workplace or 
organization may have a Jabber server you can use. For example, OS X Server comes 
with Messages server, which is based on Jabber technology.
After you set up a Jabber account, you can set up Messages to use it for one-to-one 
and multiperson conversations with other Jabber users. You can also have audio and 
video chats and use screen sharing with Jabber users who have the hardware and 
software that support those capabilities.
If the service provider of your Jabber account uses a “federated” messaging network, 
you can send messages to other Jabber users whose service providers also use 
federated networks. You can also add those Jabber users to the buddy list for your 
Jabber account.
For example, because Google Talk is a Jabber-based service that uses federation, you 
can chat with Google Talk subscribers if your Jabber service uses federation. You can 
also add them to the buddy list in your Jabber account.

Configuring Messages
Before you use Messages, you need to enter information for your service provider 
accounts. Messages has an assistant to guide you through adding a new account. The 
Messages assistant appears when you first open Messages or add a new account in 
Messages preferences.

Setting up your first Messages account
The first time you open Messages, an iMessage dialog appears and you can enter your 
Apple ID. If you don’t want to use iMessage, you can simply click Not Now to skip this 
step.
Next, the assistant prompts you to add a Google, Yahoo, AOL, or other account. Click 
Cancel to skip this step if you don’t want to use an instant messaging account at this 
time.
To set up iMessage:

1. Choose Messages > Preferences, and click Accounts.
2. Select iMessage in the Accounts list.
3. Enter your Apple ID and password, then click Sign In.
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If you don’t have an Apple ID, click Create Apple ID, enter the requested information, 
and click Create Apple ID.

4. In the “You can be reached for messages at” list, enter the email addresses you want to 
use for iMessages.
When you enter an email address that isn’t associated with your Apple ID, a verification 
email is sent to that email address. You’ll need to click the Verify Now link in the 
verification email before you can receive messages sent to that email address in 
Messages. All unverified email addresses are marked with “Waiting to Verify.”
An email address can be associated with only one Apple ID at a time. 

5. Select “Enable this account.”
• You can now send unlimited iMessages to anyone with a Mac or iOS device. If you 

have an iPhone, you can send and receive SMS text messages from your Mac.
• To Receive iMessages sent to email addresses and phone numbers, click Add Email. 

Then enter an email address or phone number. Select the email addresses and 
phone numbers you want to use to receive messages.

• If you add a new email address for your Apple ID, you’ll receive a validation email at 
that address. Follow the instructions in the email so you can use the address with 
Messages.

• If your phone number is associated with your Apple ID, it’s automatically added to 
the list. For instance, if you set up your iPhone with your Apple ID, your phone 
number is associated with your Apple ID.

Adding accounts
Before you start, have information about your existing accounts available.
To get your account information or sign up for Google, Yahoo, or AOL accounts, go to 
their websites. If you need a Jabber account, contact the administrator of the Jabber 
server you’ll use.
You can enter your messaging account information in Messages or in the Internet 
Accounts pane of System Preferences.
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To set up additional accounts in Messages:
1. Choose Messages > Add Account.
2. Choose the type of account you want to use. If you want to add a Jabber account, 

choose “Other messages account,” click Continue, and choose Jabber from the Account 
Type pop-up menu.

3. Enter your account information.
• AIM: Enter your AIM user name (for example, dbecker3), or me.com or Mac.com 

email address (for example, dbecker3@me.com or dbecker3@mac.com) and 
password.

• Jabber: Enter your Jabber account name (for example, dbecker@jabber.org) and 
password.
If your Jabber service provider gave you specific server information, enter it under 
Server Options.

• Google Talk: Enter your Google Talk account name (for example, 
dbecker3@gmail.com) and password.

• Yahoo!: Enter your Yahoo user name (for example, dbecker) and password.
4. Click Create.

Messages should connect to the Messages service, and you may see contacts with AIM 
or Messages accounts from your Contacts listed in your Buddies list. If you don’t have 
any contacts with AIM or Messages accounts, your Buddies list will be empty.
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Chat on your local network
You can use Bonjour to send messages to other Messages users on your local network 
without using a messaging account or server. Using Bonjour, computers communicate 
directly with each other.
Important: Before using Bonjour to send someone a message, you may want to verify 
the person’s identity. The names shown in the Bonjour window are based on the 
person’s card in the Contacts app and may not match the person’s actual name. Your 
Bonjour name is shown at the top of your buddy list.
• When you send a message and enter someone’s name in the To field, select his or 

her Bonjour name to send a message through Bonjour.
• Double-click a name in the Bonjour buddy list to send a message.

If you don’t see the Bonjour buddy list, choose Window > Buddies. If all your 
buddies are shown in one buddy list, Bonjour users are listed under “Bonjour” in the 
list.

To turn off Bonjour messaging, choose Messages > Preferences, click Accounts, select 
Bonjour, and deselect “Enable Bonjour instant messaging.”
If you connect to the Internet using Point-to-Point Protocol (PPP) or Point-to-Point 
Protocol over Ethernet (PPPoE), you won’t see other Bonjour users. If you connect via a 
shared network segment, which is common with cable modems, you may see other 
Messages users.
If your computer is protected by a firewall, you might not be able to receive messages 
from other Bonjour users. To use Bonjour, you need to change your firewall settings to 
allow activity on port 5298.
A network administrator may be able to adjust your network settings if you have 
trouble using Bonjour.

Summary
In this chapter, you learned how to use instant messaging with your Mac so you can 
collaborate instantly with your colleagues. You should now be able to:
• Configure Messages to send messages to iPhone, iPad, iPod touch, Mac, and PC 

users.
• Configure Messages for use with AIM, Jabber, Google Talk, and Yahoo.
• Use Messages to communicate with other Messages users on your local network.
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Data Management and Backup

When you switch from a Windows computer to a Mac, you can transfer many of your 
PC files and use them just as you did before. Common Windows file formats—
including text and PDF documents, images, audio, and video files—can easily be 
opened in OS X. The first step is to migrate your files from your Windows computer to 
your Mac.
In addition to migrating your data, it’s also important to protect your data. You should 
make regular backups of your system and keep multiple backups of important files. 
Your organization may have a specific backup policy to follow. Even if it doesn’t, a 
personal backup strategy is always a good practice.
In this chapter, you’ll learn how to migrate your Windows data to a Mac through 
various transfer methods. Then you’ll learn how to set up a backup strategy to protect 
your important data from potential loss.

Migrating data from Windows to a Mac
You can connect the Mac and PC through a network and use Migration Assistant. If 
you have a small number of files, you can copy them from your PC onto external or 
removable storage media and use the media in your Mac, or you can send Windows 
files to your Mac over the Internet using email.

Transferring your information from a PC with Migration Assistant
With Migration Assistant, you can transfer your user account—including all your 
photos, music, and files—from a PC to your Mac. If you didn’t transfer your information 
to your Mac when you first set it up, you can use Migration Assistant to transfer your 
information at any time.
You can transfer information over a wired or wireless network. Make sure your 
computers are connected to the same network.
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To transfer your information:
1. On the PC, download the Windows Migration Assistant installer from Apple Support 

Downloads.
2. Install Windows Migration Assistant. Then open it.
3. Click Continue.
4. On the Mac, open the Migration Assistant located in the Utilities folder. To open it, in 

Finder, choose Go > Utilities, or press Shift–Command–U (⇧⌘U). Then double-click 
Migration Assistant.

5. Select “From a Windows PC.” Then click Continue.
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6. When prompted, enter an administrator name and password.
7. Select the PC. Then wait for the PC to show the passcode displayed on the Mac.

8. On the PC, when you see the passcode displayed on the Mac, click Continue to 
proceed.

9. After you verify that the same passcode is displayed on your Mac and PC, use your Mac 
to select the information you want to transfer from on your PC.
• User accounts: Select the checkbox next to the user’s name. 

The user’s pictures, movies, music, documents, downloads, email (from POP and 
IMAP accounts), contacts, calendars, purchased iOS apps, bookmarked websites, and 
settings will be transferred. 

• Computer settings: Select the Settings checkbox (in a user account). The desktop 
picture, set language, and location will be transferred. Network settings and 
passwords aren’t transferred.

• Email from a POP account in Microsoft Outlook on Windows (XP, Vista, 7, or 8) is 
transferred only for the logged-in user.

• Contacts from Microsoft Outlook on Windows (XP, Vista, 7, or 8) are transferred only 
for the logged-in user.

10. Click Continue to begin the transfer.
A progress bar appears on both the Windows PC and Mac, showing what’s being 
migrated and the estimated time remaining. When migration is complete, you can log 
in to the user account you created.
• If you had a custom desktop picture on your PC, it’s set automatically as your 

desktop picture on your Mac. To change your desktop picture, use Desktop & Screen 
Saver preferences.
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• Your email accounts, which include your email messages and attachments, are set 
up in Mail.

• Your contacts are in Contacts.
• Your calendar accounts, which include your meetings and events, are set up in 

Calendar.
• Your web browser’s bookmarks, favorites, and home page are set up in Safari.
• iOS apps that you bought in iTunes on your PC are in iTunes on your Mac. If your 

music was in iTunes on your PC, your music is also in iTunes on your Mac.
• Files from the My Documents, My Videos, My Music, or My Pictures folders are in the 

Documents, Movies, Music, or Pictures folders in the Finder, respectively.
• Files from the PC’s desktop are on your Mac desktop.
For more information about using Migration Assistant, refer to Apple Support article 
HT4796, About Windows Migration Assistant, at http://support.apple.com/kb/HT4796?
viewlocale=en_US.

Backing up data
The best way to protect your data from loss as a result of hardware failure, user error, 
data corruption, or equipment theft is to back up frequently. OS X includes Time 
Machine, an app that can automatically back up your system and your important, 
irreplaceable files to a hard disk or network volume.

Backing up data with Time Machine
Time Machine makes it easy to restore your files or your entire system. In its default 
configuration, Time Machine keeps an up-to-date copy of the important data on your 
Mac—including apps, digital photos, music, movies, and documents. You can easily go 
“back in time” to restore files if you need to. Time Machine ignores some file types by 
default, such as Safari caches and certain basic system files. 
Time Machine can back up to any locally connected Mac OS Extended volume that is 
not the startup volume.
To configure Time Machine:

1. Connect a FireWire, USB, or Thunderbolt hard drive to your Mac.
You can also use a secondary internal disk (a disk that your Mac doesn’t use as a 
startup disk).

2. If you haven’t specified a backup disk yet, Time Machine asks whether you want to use 
the newly connected disk as a backup disk.
Click “Use as Backup Disk” to confirm that you want to use the disk for Time Machine 
backups.
Time Machine preferences opens with this disk selected as your backup device.
That’s all you have to do for Time Machine to automatically back up your Mac. The first 
backup may take awhile, and you may want to set up Time Machine in the evening so 
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that the initial backup can be done overnight. By default, Time Machine keeps hourly 
backups for the past 24 hours, daily backups for the past month, and weekly backups 
until your backup disk is full.
To manually select a Time Machine backup disk:

1. Choose Apple menu > System Preferences.
2. Click Time Machine.

3. Click Select Backup Disk.
All suitable volumes, other than your startup disk, are listed.

4. Choose a disk where you want backups to be stored. Then click Use Disk.
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Alternate backup methods
In addition to hard drives, you can back up your data to a network or cloud-based 
server.
Follow these steps if you have a network home folder set up at your organization.
To back up to a disk on a network, the network server must use AFP file sharing and 
both your Mac and the network backup disk should have OS X v10.5.6 or later 
installed. To make the network server available to Time Machine, first make sure you’ve 
mounted it as a shared volume on your Mac using the Go > “Connect to Server” 
command from the Finder.
To back up to a server:

1. Choose Apple menu > System Preferences.
2. Click Time Machine.
3. Click Select Backup Disk.
4. Choose a network server where you want to store backups. Then click Use Disk.

Summary
In this chapter, you learned about managing data and different ways to migrate your 
files from a Windows computer. You also learned how to back up your information 
with your Mac and protect against data loss and potential financial risk. Time Machine 
makes the process easy.
You should now be able to:
• Migrate data from a Windows computer to your Mac.
• Configure Time Machine for use with an external hard drive.
• Back up data on a regular basis with Time Machine.
• Back up data to a server.
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Cross-Platform Compatibility

With OS X, you can seamlessly integrate your Mac into Windows and mixed operating 
system network environments. You can use Microsoft Office, connect to most printers 
and cameras, join PC networks, and even run Windows on your Mac. OS X includes 
built-in support for the latest version of Microsoft Exchange Server, so you can use 
your Mac with all the features and apps you love—at home and at work—and have all 
your messages, meetings, and contacts in one place.
A native version of Microsoft Office is available for OS X. It features a Mac-friendly 
interface, so you can create documents with Word, presentations with PowerPoint, and 
spreadsheets with Excel just like on a Windows PC. Your Mac is compatible with 
Microsoft Office for Windows, so you can easily share documents with friends and 
colleagues who use Windows.
Most popular Mac apps use the same file format as their Windows counterparts, 
making it easy to open and use files created on Windows computers on your Mac. For 
common files types and extensions, refer to http://support.apple.com/kb/PH14021.
Even if you don’t have Office installed on your Mac, you can use Quick Look to take a 
peek at Office documents without opening an app. 
On any new Mac, you can install Windows 7 or Windows 8 operating systems and run 
them at native speeds with Boot Camp. Setup is simple and safe for your Mac files. 
After you’ve completed the installation, you can start up your Mac using either OS X or 
Windows. Or, if you want to run Windows and Mac apps at the same time without 
restarting, you can install Windows in OS X using VMware or Parallels software.
In this chapter, you’ll learn about apps with versions available for both Mac and 
Windows. You’ll also learn about Mac apps with built-in support for Windows files. And 
you’ll learn how to set up your Mac to run the Windows operating system natively 
with Boot Camp and virtually with VMware Fusion and Parallels Desktop.
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Using both operating systems
You can work with Windows files in OS X using apps that have versions available for 
both operating systems. Alternatively, many Mac-only apps can import files formatted 
for  Windows file formats.

Cross-platform apps
Software developers offer versions of their apps for both Windows and OS X to 
accommodate the mixed operating system environments that many organizations use.
Available cross-platform productivity apps include:
• Microsoft Office, with Word, Excel, Messenger, and PowerPoint
• Adobe Acrobat, Photoshop, Illustrator, InDesign, After Effects, and Premiere Pro
• QuickBooks from Intuit
• FileMaker

Cross-platform file types
Many native Mac apps can import and export files created in Windows. With these 
apps, you can also view most common file types, including Office documents, PDFs, 
images, text files, MP3s, videos, and ZIP files.
Mac apps with support for Windows files include:
• Pages, which can import and export Microsoft Word and most other Windows text 

formats
• Numbers, which can import and export Excel as well as Open Financial Exchange 

files from Quicken, comma-separated-values files, and tab-delimited files
• Keynote, which can import and export PowerPoint presentations
• Any QuickTime-compatible app, which can import .avi video and .wav audio files

Running Windows on a Mac
An Intel-based Mac uses the same processor as a computer running Windows, 
enabling it to directly run Windows software in a variety of ways. You can boot the 
Windows operating system natively on a Mac by using the Boot Camp software, which 
is included with OS X. You can also run Windows directly in OS X with virtualization 
apps such as VMware Fusion and Parallels Desktop, which create virtual Windows 
computers on your Mac desktop. In this section, you’ll learn how to configure Boot 
Camp and you’ll learn about virtualization.
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Boot Camp
You can use Boot Camp to install Windows on a Mac computer in its own partition, 
using a Microsoft Windows installation disc that you provide. After installation, you can 
use either Windows or OS X on your Mac. While using Boot Camp, Windows apps have 
full access to multiple processors and multiple cores, accelerated 3D graphics, and 
high-speed ports and networking technology such as USB, FireWire, Thunderbolt, Wi-
Fi, AirPort, and Gigabit Ethernet. 
Installing Windows on your Mac computer involves the following steps:
Step 1: Back up your files
Step 2: Check for updates.
Step 3: Prepare your Mac for Windows.
Step 4: Install Windows.
Step 5: Install the Windows support software.
Please check that you have the following prior to the installation:

• The keyboard and mouse or trackpad that came with your Mac. (If they aren’t 
available, use a USB keyboard and mouse.)

• An external USB drive (a hard drive or a flash drive) that is 8GB or greater, formatted 
as MS-DOS (FAT). To format an external USB drive as MS-DOS (FAT), use Disk Utility, 
located in the Other folder in Launchpad.

• A Windows ISO image (a disk image that contains the entire contents of a DVD) 
downloaded from Microsoft, or both a Windows full-install installation disc and a 
built-in disk drive or compatible external optical drive. If you have a Windows DVD 
and an optical drive, follow the instructions in the Apple support article Creating an 
ISO image from a Windows installation DVD.
The Windows ISO image or DVD must be of the 64-bit version of Windows 7 Home 
Premium, Windows 7 Professional, Windows 7 Ultimate, Windows 8, Windows 8 Pro, 
Windows 8.1, or Windows 8.1 Pro.

• At least 30GB of free space on an internal hard drive.
The following instructions present an overview of the steps required to install 
Windows on a Mac computer. However, you should review Boot Camp Help, which is 
available in the Boot Camp Assistant.
Step 1: Back up your files

Before you install Windows, make sure you back up important files. You can use Time 
Machine or another method to back up your files.
For more information about backing up files, refer to the “Backing up data” section in 
the “Data Management and Backup” chapter of this guide.
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Step 2: Check for updates
1. Log in to an administrator account on your Mac, quit all open apps, and log out any 

other users on the computer.
2. In the App Store, check for available updates.

If your computer restarts after installing an update, choose Apple menu > Software 
Update again to install any additional updates.

3. Go to www.apple.com/support/bootcamp to see if you need additional updates.
Step 3: Prepare your Mac for Windows

Boot Camp Assistant helps prepare your Mac for Windows by downloading the 
necessary support software, creating a new partition for Windows, and starting the 
Windows installer.

1. Connect an external hard drive or insert a flash drive into the USB port on your Mac; 
keep it connected or inserted while you install Windows and the Windows support 
software.

2. Open Boot Camp Assistant located in the Other folder in Launchpad.

3. Click Continue.
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4. Select the option to install Windows, and select any other options you need.

5. Click Continue.
6. If you selected the “Create a Windows 7 or later version install disk” option, follow the 

onscreen instructions for creating a bootable USB drive. Then click Continue.
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7. Follow the onscreen instructions for saving the Windows support software to an 
external disk.

8. Click Continue.
9. When you’re asked to create a Windows partition, specify a partition size.

If you need help determining the best size for your Windows partition, refer to your 
Windows installer documentation. For Windows 8, create a partition that is at least 
30GB.
In a later step, you’ll format the Windows partition.

10. Click Install.
Boot Camp Assistant creates the Windows partition, restarts your Mac, and opens the 
Windows installer.
Step 4: Install Windows

Refer to your Windows documentation for general information about installing and 
setting up Windows.
If you’ve already quit Boot Camp Assistant without installing Windows, open Boot 
Camp Assistant and continue from where you left off.
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1. Follow the onscreen instructions in the Windows installer until you’re asked whether to 
do an upgrade or a custom installation. Choose Custom.

2. When you’re asked where to install Windows, select the partition named BOOTCAMP.
WARNING: Do not create or delete a partition, or select any other partition. Doing so 
may delete the entire contents of your OS X partition.

3. Click “Drive options (advanced)” or Format. (These options may vary depending on 
your installation.)

4. Click Format, and click OK.
5. Click Next. The installer formats the Windows partition using the New Technology File 

System (NTFS).
6. Follow the onscreen instructions to finish installing and configuring Windows.

After you install the Windows software, your Mac will automatically restart using 
Windows. Use the Windows setup screens to configure Windows.
Step 5: Install the Windows support software

After installing Windows, install Mac-specific drivers and other support software for 
Windows. The support software installs Boot Camp drivers to support your Mac 
hardware, including AirPort, the built-in camera, the Apple Remote, the trackpad on a 
portable Mac, and the function keys on an Apple keyboard. The software also installs 
the Boot Camp control panel for Windows and the Apple Boot Camp system tray item.
You can download the support software by selecting the “Download the latest 
Windows support software from Apple” option in Boot Camp Assistant. The support 
software must be copied to a USB flash drive formatted as MS-DOS (FAT).

1. An installer may start automatically. If it doesn’t, double-click the setup.exe file in the 
Boot Camp folder on the USB flash drive that has the support software.

2. Follow the onscreen instructions.
Important: Don’t click the Cancel button in any of the installer dialogs.
If a message appears that says the software you’re installing hasn’t passed Windows 
Logo testing, click Continue Anyway.
You don’t need to respond to installer dialogs that appear briefly during the 
installation.
If nothing appears to be happening, there may be a hidden window that you must 
respond to. Check the taskbar and look behind any windows that are open.

3. After your Mac restarts, follow the instructions for any other installers that appear.
4. Check for updated Windows support software by using Apple Software Update or 

going to www.apple.com/support/bootcamp.
After you’ve installed Windows and the Boot Camp drivers, you can start using 
Windows on your Mac. Boot Camp makes it easy to start up your computer using 
either OS X or Windows. You can set the default operating system for your computer 
using Startup Disk preferences (OS X) or the Boot Camp control panel (Windows). You 
can also select an operating system when your computer starts up.
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Virtualization
If you need to run Windows apps only occasionally or don’t need the increased 
performance of Boot Camp, virtualization offers instant access to Windows without 
having to leave OS X. VMware Fusion and Parallels Desktop are two popular third-party 
Windows virtualization solutions.
VMware Fusion

To download and purchase VMware Fusion, visit www.vmware.com/products/fusion/.
Parallels Desktop

To download and purchase Parallels Desktop, visit www.parallels.com/products/
desktop/.
Note: In addition to the virtualization software, you’ll need a full-install Windows 
installation disc or a Windows ISO image of the Windows version you want to use.

Summary
In this chapter, you learned about the cross-platform compatibility of OS X, enabling 
you to work seamlessly with Windows users.
You should now be able to:
• List apps that are available on both Windows and OS X.
• List native Mac apps that support Windows file formats.
• Configure a Mac to run Windows natively with Boot Camp.
• List third-party virtualization options for running Windows.
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Additional Resources

Mac Integration Basics exam
Add Apple Certified Associate - Mac Integration 10.10 to your credentials. Instructions 
for taking the online exam are at training.apple.com/itpro/macinteg/1010exam 

OS X training and certification
Apple offers comprehensive certification programs for IT professionals in business, 
education, and other fields. Review the training and certification options below to find 
the path best suited to your goals.

OS X courses
Courses are taught by Apple Certified Trainers through a worldwide network of Apple 
Authorized Training Centers (AATCs).
OS X Support Essentials 10.10: Provides an intensive and in-depth exploration of 
troubleshooting on OS X, touring the breadth of functionality of OS X systems.
OS X Server Essentials 10.10: Gives technical coordinators and entry-level system 
administrators the knowledge to implement a OS X Server–based system.

OS X Certifications
Apple’s OS X Certifications are designed for IT professionals who:
• Support OS X users in a business, education institution, or school district
• Manage networks of OS X systems in an organization—for example, a teacher or a 

technology specialist who manages classroom networks or computer labs
• Manage complex, multiplatform networks that include OS X systems
Apple Certified Associate - Mac Integration certification verifies an understanding of 
the different ways to integrate a Mac within a Windows- or other standards-based 
network.
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Apple Certified Associate - Mac Management certification verifies a basic 
understanding of the different methods for deploying and managing Mac computers.
Apple Certified Support Professional (ACSP) is next on the OS X certification path, 
validating basic OS X support and troubleshooting skills.
Apple Certified Technical Coordinator (ACTC) certification builds on ACSP by certifying 
essential OS X Server support and troubleshooting skills.
For more information about all available Apple Certifications, visit training.apple.com.

Books
The Apple Training Series books constitute a key part of Apple’s official curriculum, 
covering OS X and OS X Server. These books offer an independent approach to 
training and certification, guiding students step by step through real-world projects. 
The books are also excellent references for performing specific tasks and technologies.
There are two titles in the Apple Training Series, written for IT support and system 
administration personnel:
• OS X Support Essentials
• OS X Server Essentials
For more information about the books, visit Peachpit Press at www.peachpit.com/
appleprotraining.

Support
Apple provides online support at www.apple.com/support, where you can access 
technical articles, download manuals, and join discussion forums.
Mac Basics on the Apple Support site provides online training materials for those who 
are new to OS X. Mac Basics is located online at www.apple.com/support/macbasics/.
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